isInsideOrOnTriangle MethodStatic

Examine a point's barycentric coordinates to determine if it lies inside the triangle or on an edge/vertex.

  • No parametric tolerance is used.
  • It is assumed b0 + b1 + b2 = 1.

isInsideOrOnTriangle(b0: number, b1: number, b2: number): boolean

@returns whether the point with barycentric coordinates is inside or on the triangle.

Parameter Type Description
b0 number  
b1 number  
b2 number  

Returns - boolean

whether the point with barycentric coordinates is inside or on the triangle.

Defined in

Last Updated: 28 October, 2024