radiansToSignedPeriodicFractionStartEnd MethodStatic
Return the fractionalized position of the given angle (as radians) computed with consideration of 2PI period and with consideration of angle sweep direction (CW or CCW).
- the start angle is at fraction 0
- the end angle is at fraction 1
- interior angles are between 0 and 1
- negative fraction for angles "before" the start angle
- fraction larger than one for angles "after" the end angle
- allows period shift
radiansToSignedPeriodicFractionStartEnd(radians: number, radians0: number, radians1: number): number
Parameter | Type | Description |
---|---|---|
radians | number | |
radians0 | number | |
radians1 | number |
Returns - number
Defined in
- geometry3d/AngleSweep.ts Line 326
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.