angleToUnboundedFraction Method
Return the fractionalized position of the given angle (as Angle) computed without consideration of 2PI period and without consideration of angle sweep direction (CW or CCW).
- the start angle is at fraction 0
- the end angle is at fraction 1
- interior angles are between 0 and 1
- negative fraction for angles "before" the start angle if start < end
- fraction larger than one for angles "after" the end angle if start < end
- fraction larger than one for angles "before" the start angle if start > end
- negative fraction for angles "after" the end angle if start > end
- does not allow period shift
angleToUnboundedFraction(theta: Angle): number
Parameter | Type | Description |
---|---|---|
theta | Angle |
Returns - number
Defined in
- geometry3d/AngleSweep.ts Line 240
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.