evaluateBasisFunctions Method
Evaluate basis functions f[] at knot value u.
evaluateBasisFunctions(knotIndex0: number, u: number, f: Float64Array): boolean
@returns true if and only if output array is sufficiently sized
Parameter | Type | Description |
---|---|---|
knotIndex0 | number | |
u | number | knot value for evaluation |
f | Float64Array | preallocated output array of order basis function values |
Returns - boolean
true if and only if output array is sufficiently sized
Defined in
- bspline/KnotVector.ts Line 312
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.