knotToPoint Method
- evaluate the surface and return the cartesian (weight = 1) point.
- if the surface XYZW point has weight0, returns point3d at 000.
knotToPoint(knotU: number, knotV: number, result?: Point3d): Point3d
Parameter | Type | Description |
---|---|---|
knotU | number | u direction knot |
knotV | number | v direction knot |
result | Point3d | optional result |
Returns - Point3d
Defined in
- bspline/BSplineSurface.ts Line 1097
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.