copyPointsAndWeights Method
Unpack the control points to a Point3d array and an array of weights.
copyPointsAndWeights(points: Point3d[], weights: number[], formatter: (x: number, y: number, z: number) => any...): void
Parameter | Type | Description |
---|---|---|
points | Point3d[] | output xyz, weighted by default formatter |
weights | number[] | output weights |
formatter | (x: number, y: number, z: number) => any | optional xyz formatter. By default, returns a Point3d of form [wx,wy,wz]. |
Returns - void
Defined in
- bspline/BSplineSurface.ts Line 843
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.