fractionToPointAndDerivatives Method
evaluate the surface at u and v fractions.
fractionToPointAndDerivatives(fractionU: number, fractionV: number, result?: Plane3dByOriginAndVectors): Plane3dByOriginAndVectors
@returns plane with origin at the surface point, direction vectors are derivatives in the u and v directions.
@returns Returns point and derivative directions.
Parameter | Type | Description |
---|---|---|
fractionU | number | u coordinate, as a fraction of the knot range. |
fractionV | number | v coordinate, as a fraction of the knot range. |
result | Plane3dByOriginAndVectors | optional pre-allocated object for return values. |
Returns - Plane3dByOriginAndVectors
plane with origin at the surface point, direction vectors are derivatives in the u and v directions.Returns point and derivative directions.
Defined in
- bspline/BSplineSurface.ts Line 775
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.