create MethodStatic
Create a bspline surface.
- This
create
variant takes control points in a "flattened" array, with points from succeeding U rows packed together in one array. UsecreateGrid
if the points are in a row-by-row grid structure - knotArrayU and knotArrayV are optional -- uniform knots are implied if they are omitted (undefined).
- When knots are given, two knot count conditions are recognized:
- If poleArray.length + order == knotArray.length, the first and last are assumed to be the extraneous knots of classic clamping.
- If poleArray.length + order == knotArray.length + 2, the knots are in modern form that does not have the classic unused first and last knot.
create(controlPointArray: Float64Array | Point3d[], numPolesU: number, orderU: number, knotArrayU: Float64Array | number[], numPolesV: number, orderV: number, knotArrayV: Float64Array | number[]): undefined | BSplineSurface3d
Parameter | Type | Description |
---|---|---|
controlPointArray | Float64Array | Point3d[] | Array of points, ordered along the U direction. |
numPolesU | number | |
orderU | number | order for the U direction polynomial (order is one more than the degree . "cubic" polynomial is order 4.) |
knotArrayU | Float64Array | number[] | knots for the V direction. See note above about knot counts. |
numPolesV | number | |
orderV | number | order for the V direction polynomial (order is one more than the degree . "cubic" polynomial is order 4.) |
knotArrayV | Float64Array | number[] | knots for the V direction. See note above about knot counts. |
Returns - undefined | BSplineSurface3d
Defined in
- bspline/BSplineSurface.ts Line 630
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.