createThroughPoints MethodStatic
Greville knot algorithm: alternative to traditional c2 cubic algorithm allowing for any order, but no end conditions or periodicity.
createThroughPoints(points: IndexedXYZCollection | Point3d[], order: number): undefined | BSplineCurve3d
Parameter | Type | Description |
---|---|---|
points | IndexedXYZCollection | Point3d[] | pass-through points. |
order | number | bspline order (1 more than degree) |
Returns - undefined | BSplineCurve3d
Defined in
- bspline/BSplineCurveOps.ts Line 29
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.