getPolePoint4d MethodAbstract
Return a specified pole as a Point4d.
- BSplineCurve3d appends weight 1 to its xyz
- BSplineCurve3dH with pole whose "normalized" point is (x,y,z) but has weight w returns its weighted (wx,wy,wz,w)
getPolePoint4d(poleIndex: number, result?: Point4d): undefined | Point4d
Parameter | Type | Description |
---|---|---|
poleIndex | number | |
result | Point4d |
Returns - undefined | Point4d
Defined in
- bspline/BSplineCurve.ts Line 220
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.