create MethodStatic

Create a bspline with given knots.

  • The poles have several variants:
    • Float64Array(3 * numPoles) in blocks of [x,y,z]
    • Point3d[]
    • number[][], with inner dimension 3
  • Two count conditions are recognized:
    • If poleArray.length + order === knotArray.length, the first and last are assumed to be the extraneous knots of classic clamping.
    • If poleArray.length + order === knotArray.length + 2, the knots are in modern form.

create(poleArray: Float64Array | number[][] | Point3d[], knotArray: Float64Array | number[], order: number): undefined | BSplineCurve3d

Parameter Type Description
poleArray Float64Array | number[][] | Point3d[]  
knotArray Float64Array | number[]  
order number  

Returns - undefined | BSplineCurve3d

Defined in

Last Updated: 28 October, 2024