spanFractionsToBasisFunctions Method
Evaluate basis functions given
- choice of u or v
- span index
- local fraction within the span.
spanFractionsToBasisFunctions(select: UVSelect, spanIndex: number, spanFraction: number, f: Float64Array, df?: Float64Array): boolean
@returns true if and only if output arrays are sufficiently sized
Parameter | Type | Description |
---|---|---|
select | UVSelect | |
spanIndex | number | |
spanFraction | number | |
f | Float64Array | |
df | Float64Array |
Returns - boolean
true if and only if output arrays are sufficiently sized
Defined in
- bspline/BSplineSurface.ts Line 341
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.