isWrappedGrid MethodStatic
Test if leading and trailing blocks of points match in a given direction.
isWrappedGrid(data: Float64Array, numRows: number, numColumns: number, dimension: number, blockLength: number, select: UVSelect): boolean
@returns true if coordinates matched
Parameter | Type | Description |
---|---|---|
data | Float64Array | packed array of points in row-major order (numRows x numColumns x dimension numbers) |
numRows | number | number of rows of points in the array |
numColumns | number | number of columns of points in the array (equal to the number of points in each row) |
dimension | number | point dimension (e.g., 2,3,4) |
blockLength | number | number of leading/trailing points to check |
select | UVSelect | 0 to test first/last columns of points; 1 to test first/last rows of points |
Returns - boolean
true if coordinates matched
Defined in
- bspline/BSplineSurface.ts Line 493
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.