getPoint3dPoleXYZW Method
Get the indexed Point3d, projecting the weight away to get to xyz.
- (IMPORTANT) This assumes this is an xyzw surface. Data will be incorrect if this is an xyz surface.
getPoint3dPoleXYZW(i: number, j: number, result?: Point3d): undefined | Point3d
Parameter | Type | Description |
---|---|---|
i | number | index in [0, numPolesU) |
j | number | index in [0, numPolesV) |
result | Point3d |
Returns - undefined | Point3d
Defined in
- bspline/BSplineSurface.ts Line 209
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.