constructor MethodProtected
initialize arrays for given spline dimensions. coffs length must be poleLength * numPolesU * numPolesV !!!!
BSpline2dNd(numPolesU: number, numPolesV: number, poleLength: number, knotsU: KnotVector, knotsV: KnotVector, coffs: Float64Array): BSpline2dNd
Parameter | Type | Description |
---|---|---|
numPolesU | number | |
numPolesV | number | |
poleLength | number | |
knotsU | KnotVector | |
knotsV | KnotVector | |
coffs | Float64Array |
Returns - BSpline2dNd
Defined in
- bspline/BSplineSurface.ts Line 311
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.