evaluateBuffersInSpan1 Method
- Evaluate the basis functions and one derivative at spanIndex and fraction.
- Evaluations are stored in the preallocated
this.basisBuffer
- Evaluations are stored in the preallocated
- Immediately do the summations of the basis values times the respective control points
- Summations are stored in the preallocated
this.poleBuffer
andthis.poleBuffer1
- Summations are stored in the preallocated
evaluateBuffersInSpan1(spanIndex: number, spanFraction: number): void
Parameter | Type | Description |
---|---|---|
spanIndex | number | |
spanFraction | number |
Returns - void
Defined in
- bspline/BSpline1dNd.ts Line 115
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.