evaluateBuffersInSpan Method
- Evaluate the basis functions at spanIndex and fraction.
- Evaluations are stored in the preallocated
this.basisBuffer
- Evaluations are stored in the preallocated
- Immediately do the summations of the basis values times the respective control points
- Summations are stored in the preallocated
this.poleBuffer
- Summations are stored in the preallocated
evaluateBuffersInSpan(spanIndex: number, spanFraction: number): void
Parameter | Type | Description |
---|---|---|
spanIndex | number | |
spanFraction | number |
Returns - void
Defined in
- bspline/BSpline1dNd.ts Line 105
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.