getPolePoint3d MethodAbstract
Get pole i
as a Point3d.
- For 3d curve, this is simple a pole access, and only fails (return
undefined
) for invalid index - For 4d curve, this deweights the homogeneous pole and can fail due to 0 weight.
getPolePoint3d(i: number, point?: Point3d): undefined | Point3d
Parameter | Type | Description |
---|---|---|
i | number | |
point | Point3d |
Returns - undefined | Point3d
Defined in
- bspline/BezierCurveBase.ts Line 86
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.