saturateInPlace Method
Compute new control points to "clamp" bspline unsaturated support to saturated form.
- At input time, the control points are associated with the input knots (unsaturated)
- At output, the control points are modified by repeated knot insertion to be fully clamped.
saturateInPlace(knots: KnotVector, spanIndex: number): boolean
Parameter | Type | Description |
---|---|---|
knots | KnotVector | knot values for the current (unsaturated) pole set |
spanIndex | number | index of span whose (unsaturated) poles are in the bezier. |
Returns - boolean
Defined in
- bspline/Bezier1dNd.ts Line 214
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.