saturate1dInPlace MethodStatic
Saturate a univariate bspline coefficient array in place
- On input, the array is the coefficients of one span of a bspline, packed in an array of
(knots.order)
values. - These are modified in place, and on return are a bezier for the same knot interval.
saturate1dInPlace(coffs: Float64Array, knots: KnotVector, spanIndex: number): boolean
Parameter | Type | Description |
---|---|---|
coffs | Float64Array | input as bspline coefficients, returned as bezier coefficients |
knots | KnotVector | knot vector |
spanIndex | number | index of span whose (unsaturated) poles are in the coefficients. |
Returns - boolean
Defined in
- bspline/Bezier1dNd.ts Line 260
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.