uvFractionToPointAndTangents Method
Convert fractional u and v coordinates to surface point and in-surface tangent directions.
- The vectors are expected to be non-zero tangents which can be crossed to get a normal.
- Hence they are not necessarily (a) partial derivatives or (b) Frenet vectors.
uvFractionToPointAndTangents(uFraction: number, vFraction: number, result?: Plane3dByOriginAndVectors): Plane3dByOriginAndVectors
Parameter | Type | Description |
---|---|---|
uFraction | number | fractional coordinate in u direction |
vFraction | number | fractional coordinate in v direction |
result | Plane3dByOriginAndVectors | optional pre-allocated carrier for point and vectors |
Returns - Plane3dByOriginAndVectors
Defined in
- geometry3d/GeometryHandler.ts Line 459
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.