interpolateIndexIndex Method
Interpolate the points at the given indices.
interpolateIndexIndex(index0: number, fraction: number, index1: number, result?: Point3d): undefined | Point3d
@returns undefined if an index is out of bounds
Parameter | Type | Description |
---|---|---|
index0 | number | index of point p0 within the array |
fraction | number | fraction f such that returned point is p0 + f * (p1 - p0) |
index1 | number | index of point p1 within the array |
result | Point3d | optional caller-allocated result to fill and return |
Returns - undefined | Point3d
undefined if an index is out of bounds
Defined in
- geometry3d/IndexedXYZCollection.ts Line 276
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.