ensureCapacity Method
- If the capacity (Float64Array length) is less than or equal to the requested newCapacity, do nothing.
- If the requested newCapacity is larger than the existing capacity, reallocate to larger capacity, and copy existing values.
ensureCapacity(newCapacity: number, applyGrowthFactor: booleantrue): void
Parameter | Type | Description |
---|---|---|
newCapacity | number | size of new array |
applyGrowthFactor | boolean | whether to apply the growth factor to newCapacity when reallocating |
Returns - void
Defined in
- geometry3d/GrowableFloat64Array.ts Line 181
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.