newBlockIndex MethodProtected
Return the starting index of a block of (zero-initialized) doubles at the end.
- this.data is reallocated if needed to include the new block.
- The inUse count is incremented to include the new block.
- The returned block is an index to the Float64Array (not a block index)
newBlockIndex(): number
Returns - number
Defined in
- geometry3d/GrowableBlockedArray.ts Line 138
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.