getUpVector Method
Compute the vector in the "up" direction of a specific point in world space. This is typically a unit Z vector. However, if the point is outside of the iModel's project extents and using ellipsoid globeMode, an up-vector will be computed relative to the surface of the ellipsoid at that point.
getUpVector(point: Point3d): Vector3d
Parameter | Type | Description |
---|---|---|
point | Point3d |
Returns - Vector3d
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.