calculateFrustum Method
Calculate the world coordinate Frustum from the parameters of this ViewState.
calculateFrustum(result?: Frustum): undefined | Frustum
@returns The 8-point Frustum with the corners of this ViewState, or undefined if the parameters are invalid.
Parameter | Type | Description |
---|---|---|
result | Frustum | Optional Frustum to hold result. If undefined a new Frustum is created. |
Returns - undefined | Frustum
The 8-point Frustum with the corners of this ViewState, or undefined if the parameters are invalid.
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.