attachToViewport Method
Invoked when this view becomes the view displayed by the specified Viewport. A ViewState can be attached to at most one Viewport at any given time. This method is invoked automatically by the viewport - there is generally no reason for applications to invoke it directly.
attachToViewport(_args: Viewport): void
@note If you override this method you must call super.attachToViewport
.
@throws Error if the view is already attached to any Viewport.
@see detachFromViewport from the inverse operation.
Parameter | Type | Description |
---|---|---|
_args | Viewport |
Returns - void
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.