isSubCategoryVisible Method
Determine whether geometry belonging to a specific SubCategory is visible in this viewport, assuming the containing Category is displayed.
isSubCategoryVisible(id: string): boolean
@returns true if the subcategory is visible in this viewport.
@note Because this function does not know the Id of the containing Category, it does not check if the Category is enabled for display. The caller should check that separately if he knows the Id of the Category.
Parameter | Type | Description |
---|---|---|
id | string | The Id of the subcategory |
Returns - boolean
true if the subcategory is visible in this viewport.
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.