flashedId
Getter
The Id of the currently-flashed object.
The "flashed" visual effect is typically applied to the object in the viewport currently under the mouse cursor, to indicate
it is ready to be interacted with by a tool. ToolAdmin is responsible for updating it when the mouse cursor moves.
The object is usually an Element but could also be a Model or pickable decoration produced by a Decorator.
The setter ignores any string that is not a well-formed Id64String. Passing Id64.invalid to the
setter is equivalent to passing undefined
- both mean "nothing is flashed".
flashedId: undefined | string
@throws Error if an attempt is made to change this property from within an onFlashedIdChanged event callback.
@see - onFlashedIdChanged to be notified when the flashed object changes.
- flashSettings to customize the visual effect.
Returns - undefined | string
Setter
flashedId(id: string): void
Parameter | Type | Description |
---|---|---|
id | string |
Returns - void
Defined in
Last Updated: 14 November, 2024