getFrustum Method
Get an 8-point Frustum corresponding to the 8 corners of the Viewport in the specified coordinate system.
There are two sets of corners that may be of interest. The "adjusted" box is the one that is computed by examining the "viewed extents" and moving the front and back planes to enclose everything in the view. The "unadjusted" box is the one that is stored in the ViewState.
getFrustum(sys: CoordSystemCoordSystem.World, adjustedBox: booleantrue, box?: Frustum): Frustum
@returns the view frustum
@note The "adjusted" box may be either larger or smaller than the "unadjusted" box.
Parameter | Type | Description |
---|---|---|
sys | CoordSystem | Coordinate system for points |
adjustedBox | boolean | If true, retrieve the adjusted box. Otherwise retrieve the box that came from the view definition. |
box | Frustum | optional Frustum for return value |
Returns - Frustum
the view frustum
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.