computeFitRange Method
Compute a volume in world coordinates tightly encompassing the contents of the view. The volume is computed from the union of the volumes of the
view's viewed models, including GeometricModels and reality models.
Those volumes are obtained from the TileTrees used to render those models, so any tile tree that has not yet been loaded will not contribute to the computation.
If options.baseExtents
is defined, it will be unioned with the computed volume.
If the computed volume is null (empty), a default volume will be computed from IModel.projectExtents, which may be a looser approximation of the
models' volumes.
computeFitRange(options?: ComputeSpatialViewFitRangeOptions): Range3d
@returns A non-null volume in world coordinates encompassing the contents of the view.
Parameter | Type | Description |
---|---|---|
options | ComputeSpatialViewFitRangeOptions | Options used to customize how the volume is computed. |
Returns - Range3d
A non-null volume in world coordinates encompassing the contents of the view.
Defined in
Last Updated: 28 October, 2024