ReadPixelsArgs Interface

Arguments supplied to readPixels.

Properties

Name Type Description
excludedElements Iterable<string, any, any> | undefined An optional set of Ids of elements that should not be drawn, potentially revealing other geometry they would otherwise obscure.  
excludeNonLocatable boolean | undefined If true, geometry with the "non-locatable" flag set will not be drawn, potentially revealing locatable geometry it would otherwise obscure.  
receiver Pixel.Receiver The function that will be invoked to process the captured pixel data.  
rect ViewRect | undefined The region of the viewport's contents to read.  
selector Pixel.Selector | undefined Specifies which aspects of each pixel to read.  

Defined in

Last Updated: 14 November, 2024