isOriginInView MethodStatic
Given an origin point, returns whether the point falls within the view or not. If adjustOrigin is set to true, a point outside the view will be modified to fall within the appropriate range.
isOriginInView(drawOrigin: Point3d, viewport: Viewport, adjustOrigin: boolean): boolean
Parameter | Type | Description |
---|---|---|
drawOrigin | Point3d | |
viewport | Viewport | |
adjustOrigin | boolean |
Returns - boolean
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.