run Method
Look up a tool by toolId and, if found, create an instance with the supplied arguments and run it.
run(toolId: string, ...args: any[]): Promise<boolean>
@returns true if the tool was found and successfully run.
Parameter | Type | Description |
---|---|---|
toolId | string | toolId of the immediate tool |
...args | any[] | arguments to pass to the constructor, and to run. |
Returns - Promise
true if the tool was found and successfully run.
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.