restartPrimitiveTool Method

Call from external events or immediate tools that may have invalidated the current primitive tool's state. Examples are undo, which may invalidate any references to elements, or an immediate tool that uses an edit command to write to the iModel, since immediate tools do not replace the active tool. The current primitive tool is expected to call installTool with a new instance, or exitTool to start the default tool.

restartPrimitiveTool(): Promise<void>

@note Should be called even if the primitive tool is currently suspended by a view tool or input collector.

Returns - Promise

Defined in

Last Updated: 06 September, 2024