parseAndRun Method
Run this instance of a tool using a series of string arguments. Override this method to parse the arguments, and if they're
acceptable, execute your run method. If the arguments aren't valid, return false
.
parseAndRun(..._args: string[]): Promise<boolean>
@note if you override this method, you must also override the static minArgs and maxArgs getters.
@note Generally, implementers of this method are not expected to call super.parseAndRun(...)
. Instead, call your
run method with the appropriate (parsed) arguments directly.
Parameter | Type | Description |
---|---|---|
..._args | string[] |
Returns - Promise
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.