isValidLocation Method
Checks that the adjusted point from the supplied button event is within the project extents for spatial views. The range of physical geometry should always be fully inside the project extents. Only checking the adjusted point won't absolutely guarantee that a tool doesn't create/move geometry outside the project extents, but it will be sufficient to handle most cases and provide good feedback to the user.
isValidLocation(_ev: BeButtonEvent, _isButtonEvent: boolean): boolean
@returns true if ev is acceptable.
Parameter | Type | Description |
---|---|---|
_ev | BeButtonEvent | |
_isButtonEvent | boolean |
Returns - boolean
true if ev is acceptable.
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.