FuzzySearchResult<T> Interface
Interface implemented by objects returned while iterating through FuzzySearchResults
Methods
Name |
Description |
|
getBoldMask(): boolean[] |
Return a boolean array that contains true for each letter in the matched value that was matched part of the search pattern |
|
getMatchedKey(): string |
Return the key found in this result object |
|
getMatchedValue(): string |
Return the value matched in this result object |
|
getResult(): T |
Return the current result object |
|
Defined in
Last Updated: 14 November, 2024