processDataButton MethodProtected
Orchestrates advancing the internal state of the tool on a data button event.
- Collect elements: Add to the element agenda until no additional elements are requested.
- Gather input: Initiates element dynamics and accepts additional points as required.
- Complete operation: Process agenda entries, restart or exit tool.
processDataButton(ev: BeButtonEvent): Promise<EventHandled>
@returns EventHandled.Yes if onReinitialize was called to restart or exit tool.
Parameter | Type | Description |
---|---|---|
ev | BeButtonEvent |
Returns - Promise<EventHandled>
EventHandled.Yes if onReinitialize was called to restart or exit tool.
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.