getDragSelectCandidates MethodProtected
Get element ids to process from drag box or crossing line selection. Sub-classes may override to support selection scopes or apply tool specific filtering.
getDragSelectCandidates(vp: Viewport, origin: Point3d, corner: Point3d, method: SelectionMethod, overlap: boolean): Promise<Id64Arg>
Parameter | Type | Description |
---|---|---|
vp | Viewport | |
origin | Point3d | |
corner | Point3d | |
method | SelectionMethod | |
overlap | boolean |
Returns - Promise<Id64Arg>
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.