TileParams Interface
Parameters used to construct a Tile.
Properties
Name | Type | Description | |
---|---|---|---|
contentId | string | Uniquely identifies this tile's content within the context of its TileTree. | |
contentRange | Range3d | undefined | Optionally, a volume more tightly encompassing this tile's contents. | |
isLeaf | boolean | undefined | True if this tile has no child tiles - i.e., requires no refinement. | |
maximumSize | number | The size in pixels beyond which this tile is considered too low-resolution for display. | |
parent | Tile | undefined | This tile's parent tile, if any. | |
range | Range3d | The volume of space occupied by this tile. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.