TileAdmin.Statistics Interface
Statistics regarding the current and cumulative state of the TileAdmin. Useful for monitoring performance and diagnosing problems.
Properties
Name | Type | Description | |
---|---|---|---|
decoding | TileContentDecodingStatistics | See TileContentDecodingStatistics. | |
numActiveRequests | number | The number of requests which have been dispatched but not yet completed. | |
numActiveTileTreePropsRequests | number | The number of in-flight IModelTileTreeProps requests. | |
numCanceled | number | The number of requests canceled during the most recent update. | |
numPendingRequests | number | The number of requests in the queue which have not yet been dispatched. | |
numPendingTileTreePropsRequests | number | The number of pending IModelTileTreeProps requests. | |
totalAbortedRequests | number | The total number of tiles for which content requests were dispatched and then canceled on the backend before completion. | |
totalCacheMisses | number | The total number of tiles whose contents were not found in cloud storage cache and therefore resulted in a backend request to generate the tile content. | |
totalCompletedRequests | number | The total number of completed requests during this session. | |
totalDispatchedRequests | number | The total number of tiles for which content requests were dispatched. | |
totalElidedTiles | number | The total number of tiles whose contents were not requested during this session because their volumes were determined to be empty. | |
totalEmptyTiles | number | The total number of completed requests during this session which produced an empty tile. | |
totalFailedRequests | number | The total number of failed requests during this session. | |
totalTimedOutRequests | number | The total number of timed-out requests during this session. | |
totalUndisplayableTiles | number | The total number of completed requests during this session which produced an undisplayable tile. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.