RealityDataSource.createKeyFromUrl Function
Create a RealityDataSourceKey from a tilesetUrl.
createKeyFromUrl(tilesetUrl: string, inputProvider?: RealityDataProvider, inputFormat?: RealityDataFormat): RealityDataSourceKey
@returns the RealityDataSourceKey that uniquely identify a reality data for a provider
Parameter | Type | Description |
---|---|---|
tilesetUrl | string | the reality data attachment url |
inputProvider | RealityDataProvider | identify the RealityDataProvider if known, otherwise function will try to extract it from the tilesetUrl |
inputFormat | RealityDataFormat | identify the RealityDataFormat if known, otherwise function will try to extract it from the tilesetUrl |
Returns - RealityDataSourceKey
the RealityDataSourceKey that uniquely identify a reality data for a provider
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.