validateSource MethodStatic
Allow a source of a specific format to be validated before being attached as a map-layer.
validateSource(_url: string, _userName?: string, _password?: string, _ignoreCache?: boolean, _accesKey?: MapLayerKey): Promise<MapLayerSourceValidation>
@returns Validation Status. If successful, a list of available sub-layers may also be returned.
Parameter | Type | Description |
---|---|---|
_url | string | The URL of the source. |
_userName | string | The username to access the source if needed. |
_password | string | The password to access the source if needed. |
_ignoreCache | boolean | Flag to skip cache lookup (i.e. force a new server request). |
_accesKey | MapLayerKey |
Returns - Promise<MapLayerSourceValidation>
Validation Status. If successful, a list of available sub-layers may also be returned.
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.