doPick Method

Generate a list of elements that are close to a given point.

doPick(vp: ScreenViewport, pickPointWorld: Point3d, pickRadiusView: number, options: LocateOptions, excludedElements?: Iterable<string, any, any>): number

@returns The number of hits in the hitList of this object.

Parameter Type Description
vp ScreenViewport Viewport to use for pick
pickPointWorld Point3d Pick location in world coordinates
pickRadiusView number Pick radius in pixels
options LocateOptions Pick options to use
excludedElements Iterable<string, any, any> Optional ids to not draw during pick. Allows hits for geometry obscured by these ids to be returned.

Returns - number

The number of hits in the hitList of this object.

Defined in

Last Updated: 14 November, 2024