reverseTxns Method
Reverse (undo) the most recent operation(s) to the briefcase in the current session.
reverseTxns(numOperations: number): Promise<IModelStatus>
@note If there are any outstanding uncommitted changes, they are reversed.
@note The term "operation" is used rather than Txn, since multiple Txns can be grouped together via TxnManager.beginMultiTxnOperation. So, even if numOperations is 1, multiple Txns may be reversed if they were grouped together when they were made.
@note If numOperations is too large only the number of reversible operations are reversed.
Parameter | Type | Description |
---|---|---|
numOperations | number | the number of operations to reverse. If this is greater than 1, the entire set of operations will be reinstated together when/if reinstateTxn is called. |
Returns - Promise<IModelStatus>
Defined in
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.