projectPointToLineInView MethodStatic
Return ray intersection with a line defined by a point and direction
projectPointToLineInView(spacePt: Point3d, linePt: Point3d, lineDirection: Vector3d, vp: Viewport, checkAccuDraw: booleanfalse, checkACS: booleanfalse): undefined | Point3d
@see getBoresite
Parameter | Type | Description |
---|---|---|
spacePt | Point3d | |
linePt | Point3d | |
lineDirection | Vector3d | |
vp | Viewport | |
checkAccuDraw | boolean | |
checkACS | boolean |
Returns - undefined | Point3d
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.