getWindowSizeSetting MethodStatic
Deprecated in 3.6. Use getWindowSizeAndPositionSetting.
Gets window size and position for a window, by name, from settings file, if present.
getWindowSizeSetting(windowName: string): undefined | WindowSizeAndPositionProps
@note Size and position values in the settings file will be updated differently depending on platform. On Linux values are only updated on window "unmaximize". On Windows and MacOS values are also updated on window manual resize or move. To get consistent behavior across different platforms, use getWindowSizeAndPositionSetting.
Parameter | Type | Description |
---|---|---|
windowName | string |
Returns - undefined | WindowSizeAndPositionProps
Defined in
- electron/src/backend/ElectronHost.ts Line 199
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.