AuxCoordSystem2dProps Interface
Properties of AuxCoordSystem2d
Extends
Properties
Name | Type | Description | |
---|---|---|---|
angle | AngleProps | undefined | Rotation angle | |
origin | XYProps | undefined | Origin of the AuxCoordSystem2d |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName | string | AuxCoordSystemProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
code | CodeProps | AuxCoordSystemProps | The Code for this element |
description | string | undefined | AuxCoordSystemProps | |
federationGuid | string | undefined | AuxCoordSystemProps | A FederationGuid assigned to this element. |
id | string | undefined | AuxCoordSystemProps | The Id of the entity. |
isInstanceOfEntity Readonly | undefined | undefined | AuxCoordSystemProps | A non-existent property used to discriminate between EntityProps and Entity. |
jsonProperties | any | undefined | AuxCoordSystemProps | Optional json properties of this element. |
model | string | AuxCoordSystemProps | The Id of the Model containing this element |
parent | RelatedElementProps | undefined | AuxCoordSystemProps | The Parent of this element, if defined. |
type | number | undefined | AuxCoordSystemProps | |
userLabel | string | undefined | AuxCoordSystemProps | A user-assigned label for this element. |
Defined in
- core/common/src/ViewProps.ts Line 225
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.