getImage Method
Produces a bitmap image from this gradient.
getImage(width: number, height: number): ImageBuffer
@note If this gradient uses Gradient.Mode.Thematic, then the width of the image will be 1 and the margin color will be included in the top and bottom rows.
@see Gradient.Symb.produceImage for more customization.
Parameter | Type | Description |
---|---|---|
width | number | Width of the image |
height | number | Height of the image |
Returns - ImageBuffer
Defined in
- core/common/src/Gradient.ts Line 366
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.